Sponsor: VoiceMeUp - Corporate & Wholesale VoIP Services

VoIP Mailing List Archives
Mailing list archives for the VoIP community
 SearchSearch 

[Callweaver-users] error compiling 1.9.99.20100406


 
Post new topic   Reply to topic    VoIP Mailing List Archives Forum Index -> CallWeaver Users
View previous topic :: View next topic  
Author Message
Prometheus001 at gmx.net
Guest





PostPosted: Thu Apr 08, 2010 4:18 am    Post subject: [Callweaver-users] error compiling 1.9.99.20100406 Reply with quote

Hello,

I tried to compile CW 1.9.99.20100406 with no success. In jitterbuffer I get
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’

I tried to compile without the -Werror flag but this resulted in almost
the same error.
I also tried to install trunk (same version) and older versions from
March. Always the same error.

Can someone lead me how to overcome this problem?

Best regards
Peter


Here is the error message:

make[3]: Entering directory `/usr/src/trunk/corelib/jitterbuffer'
/bin/sh ../../libtool --tag=CC --mode=compile ../../utils/cc
-DHAVE_CONFIG_H -I. -I../../include -I../../include -I../../corelib
-I../../include -include ../../include/global.h -Wall -Werror
-Wmissing-prototypes -Wmissing-declarations -Wunused-parameter -Wshadow
-Wwrite-strings -fvisibility=hidden -DCW_API_IMPLEMENTATION -g -O2
-fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT
libcwjb_la-generic_jb.lo -MD -MP -MF .deps/libcwjb_la-generic_jb.Tpo -c
-o libcwjb_la-generic_jb.lo `test -f 'generic_jb.c' || echo
'./'`generic_jb.c
../../utils/cc -DHAVE_CONFIG_H -I. -I../../include -I../../include
-I../../corelib -I../../include -include ../../include/global.h -Wall
-Werror -Wmissing-prototypes -Wmissing-declarations -Wunused-parameter
-Wshadow -Wwrite-strings -fvisibility=hidden -DCW_API_IMPLEMENTATION -g
-O2 -fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT
libcwjb_la-generic_jb.lo -MD -MP -MF .deps/libcwjb_la-generic_jb.Tpo -c
generic_jb.c -fPIC -DPIC -o .libs/libcwjb_la-generic_jb.o
*** Retry without preprocessor compile time optimizations
cc1: warnings being treated as errors
In file included from ../../include/callweaver/object.h:29,
from ../../include/callweaver/module.h:34,
from ../../include/callweaver/utils.h:37,
from ../../include/callweaver/frame.h:36,
from generic_jb.c:33:
../../include/callweaver/atomic.h: In function ‘__cmpxchg’:
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’
make[3]: *** [libcwjb_la-generic_jb.lo] Fehler 1
make[3]: Leaving directory `/usr/src/trunk/corelib/jitterbuffer'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/usr/src/trunk/corelib'
make[1]: *** [all] Fehler 2
make[1]: Leaving directory `/usr/src/trunk/corelib'
make: *** [all-recursive] Fehler 1



_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users
Back to top
Prometheus001 at gmx.net
Guest





PostPosted: Thu Apr 08, 2010 8:05 am    Post subject: [Callweaver-users] error compiling 1.9.99.20100406 Reply with quote

I just tried the same under Centos 4.5.
Same error.

Can someone lead me how to overcome this problem?


Best regards
Peter

Peter P GMX schrieb:
Quote:
Hello,

I tried to compile CW 1.9.99.20100406 with no success. In jitterbuffer I get
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’

I tried to compile without the -Werror flag but this resulted in almost
the same error.
I also tried to install trunk (same version) and older versions from
March. Always the same error.

Can someone lead me how to overcome this problem?

Best regards
Peter


Here is the error message:

make[3]: Entering directory `/usr/src/trunk/corelib/jitterbuffer'
/bin/sh ../../libtool --tag=CC --mode=compile ../../utils/cc
-DHAVE_CONFIG_H -I. -I../../include -I../../include -I../../corelib
-I../../include -include ../../include/global.h -Wall -Werror
-Wmissing-prototypes -Wmissing-declarations -Wunused-parameter -Wshadow
-Wwrite-strings -fvisibility=hidden -DCW_API_IMPLEMENTATION -g -O2
-fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT
libcwjb_la-generic_jb.lo -MD -MP -MF .deps/libcwjb_la-generic_jb.Tpo -c
-o libcwjb_la-generic_jb.lo `test -f 'generic_jb.c' || echo
'./'`generic_jb.c
../../utils/cc -DHAVE_CONFIG_H -I. -I../../include -I../../include
-I../../corelib -I../../include -include ../../include/global.h -Wall
-Werror -Wmissing-prototypes -Wmissing-declarations -Wunused-parameter
-Wshadow -Wwrite-strings -fvisibility=hidden -DCW_API_IMPLEMENTATION -g
-O2 -fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT
libcwjb_la-generic_jb.lo -MD -MP -MF .deps/libcwjb_la-generic_jb.Tpo -c
generic_jb.c -fPIC -DPIC -o .libs/libcwjb_la-generic_jb.o
*** Retry without preprocessor compile time optimizations
cc1: warnings being treated as errors
In file included from ../../include/callweaver/object.h:29,
from ../../include/callweaver/module.h:34,
from ../../include/callweaver/utils.h:37,
from ../../include/callweaver/frame.h:36,
from generic_jb.c:33:
../../include/callweaver/atomic.h: In function ‘__cmpxchg’:
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’
make[3]: *** [libcwjb_la-generic_jb.lo] Fehler 1
make[3]: Leaving directory `/usr/src/trunk/corelib/jitterbuffer'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/usr/src/trunk/corelib'
make[1]: *** [all] Fehler 2
make[1]: Leaving directory `/usr/src/trunk/corelib'
make: *** [all-recursive] Fehler 1



_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users

_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users
Back to top
Prometheus001 at gmx.net
Guest





PostPosted: Thu Apr 08, 2010 8:09 am    Post subject: [Callweaver-users] error compiling 1.9.99.20100406 Reply with quote

Sorry, I meant Centos 5.4

Best regards
Peter


Peter P GMX schrieb:
Quote:
I just tried the same under Centos 4.5.
Same error.

Can someone lead me how to overcome this problem?


Best regards
Peter

Peter P GMX schrieb:

Quote:
Hello,

I tried to compile CW 1.9.99.20100406 with no success. In jitterbuffer I get
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’

I tried to compile without the -Werror flag but this resulted in almost
the same error.
I also tried to install trunk (same version) and older versions from
March. Always the same error.

Can someone lead me how to overcome this problem?

Best regards
Peter


Here is the error message:

make[3]: Entering directory `/usr/src/trunk/corelib/jitterbuffer'
/bin/sh ../../libtool --tag=CC --mode=compile ../../utils/cc
-DHAVE_CONFIG_H -I. -I../../include -I../../include -I../../corelib
-I../../include -include ../../include/global.h -Wall -Werror
-Wmissing-prototypes -Wmissing-declarations -Wunused-parameter -Wshadow
-Wwrite-strings -fvisibility=hidden -DCW_API_IMPLEMENTATION -g -O2
-fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT
libcwjb_la-generic_jb.lo -MD -MP -MF .deps/libcwjb_la-generic_jb.Tpo -c
-o libcwjb_la-generic_jb.lo `test -f 'generic_jb.c' || echo
'./'`generic_jb.c
../../utils/cc -DHAVE_CONFIG_H -I. -I../../include -I../../include
-I../../corelib -I../../include -include ../../include/global.h -Wall
-Werror -Wmissing-prototypes -Wmissing-declarations -Wunused-parameter
-Wshadow -Wwrite-strings -fvisibility=hidden -DCW_API_IMPLEMENTATION -g
-O2 -fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT
libcwjb_la-generic_jb.lo -MD -MP -MF .deps/libcwjb_la-generic_jb.Tpo -c
generic_jb.c -fPIC -DPIC -o .libs/libcwjb_la-generic_jb.o
*** Retry without preprocessor compile time optimizations
cc1: warnings being treated as errors
In file included from ../../include/callweaver/object.h:29,
from ../../include/callweaver/module.h:34,
from ../../include/callweaver/utils.h:37,
from ../../include/callweaver/frame.h:36,
from generic_jb.c:33:
../../include/callweaver/atomic.h: In function ‘__cmpxchg’:
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’
make[3]: *** [libcwjb_la-generic_jb.lo] Fehler 1
make[3]: Leaving directory `/usr/src/trunk/corelib/jitterbuffer'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/usr/src/trunk/corelib'
make[1]: *** [all] Fehler 2
make[1]: Leaving directory `/usr/src/trunk/corelib'
make: *** [all-recursive] Fehler 1



_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users


_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users

_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users
Back to top
mjagdis at eris-associ...
Guest





PostPosted: Fri Apr 09, 2010 6:06 pm    Post subject: [Callweaver-users] error compiling 1.9.99.20100406 Reply with quote

On Thu, Apr 08, 2010 at 03:06:58PM +0200, Peter P GMX wrote:
Quote:
[...]

I tried to compile CW 1.9.99.20100406 with no success. In jitterbuffer I get
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’

I guess it's been a while since I've had anything non-64bit and the
ifdef for x86_64 is broken (possibly I was testing and forgot about it)
so that has been compiling the pthread fallback atomics rather than the
native implementation.

Either grab the latest as of today or insert a CW_UNUSED(mutex) in
atomic.h around line 99 or so - it doesn't need to be exact.
(See the changesets at http://www.callweaver.org/ if you are in
any doubt).

Mike

--
Mike Jagdis Web: http://www.eris-associates.co.uk
Eris Associates Limited Tel: +44 7780 608 368
Reading, England Fax: +44 118 926 6974
_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users
Back to top
Prometheus001 at gmx.net
Guest





PostPosted: Fri Apr 09, 2010 7:06 pm    Post subject: [Callweaver-users] error compiling 1.9.99.20100406 Reply with quote

Thanks Mike,

I compiled the newest version and had to make that entry CW_UNUSED(mutex);

Now I'm stuck with another error:
make[3]: Entering directory `/usr/src/callweaver-1.9.99.20100409/corelib'
.
.
.
../utils/cc -DHAVE_CONFIG_H -I. -I../include -include
../include/global.h -Wall -Werror -Wmissing-prototypes
-Wmissing-declarations -Wunused-parameter -Wshadow -Wwrite-strings
-fvisibility=hidden -D_REENTRANT -DCW_API_IMPLEMENTATION
-DCW_UTILSDIR="//sbin" -fomit-frame-pointer -I../libltdl -I../include
-I.. -I../include -I../include -I.. -I../include -g -O2
-fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT
callweaver-udpfromto.o -MD -MP -MF .deps/callweaver-udpfromto.Tpo -c -o
callweaver-udpfromto.o `test -f 'udpfromto.c' || echo './'`udpfromto.c
*** Retry without preprocessor compile time optimizations
cc1: warnings being treated as errors
udpfromto.c: In function ‘cw_udpfromto_init’:
udpfromto.c:39: error: unused parameter ‘s’
udpfromto.c: In function ‘cw_recvfromto’:
udpfromto.c:69: error: unused parameter ‘to’
udpfromto.c:70: error: unused parameter ‘tolen’
udpfromto.c: In function ‘cw_sendfromto’:
udpfromto.c:179: error: unused parameter ‘from’
udpfromto.c:180: error: unused parameter ‘fromlen’
make[3]: *** [callweaver-udpfromto.o] Fehler 1

Mike Jagdis schrieb:
Quote:
On Thu, Apr 08, 2010 at 03:06:58PM +0200, Peter P GMX wrote:

Quote:
[...]

I tried to compile CW 1.9.99.20100406 with no success. In jitterbuffer I get
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’


I guess it's been a while since I've had anything non-64bit and the
ifdef for x86_64 is broken (possibly I was testing and forgot about it)
so that has been compiling the pthread fallback atomics rather than the
native implementation.

Either grab the latest as of today or insert a CW_UNUSED(mutex) in
atomic.h around line 99 or so - it doesn't need to be exact.
(See the changesets at http://www.callweaver.org/ if you are in
any doubt).

Mike


_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users
Back to top
Prometheus001 at gmx.net
Guest





PostPosted: Sat Apr 10, 2010 5:40 am    Post subject: [Callweaver-users] error compiling 1.9.99.20100406 Reply with quote

I finally got 1.99 working by setting up a 64 bit system and fixing some
more errors.

Best regards
Peter

Peter P GMX schrieb:
Quote:
Thanks Mike,

I compiled the newest version and had to make that entry CW_UNUSED(mutex);

Now I'm stuck with another error:
make[3]: Entering directory `/usr/src/callweaver-1.9.99.20100409/corelib'
.
.
.
../utils/cc -DHAVE_CONFIG_H -I. -I../include -include
../include/global.h -Wall -Werror -Wmissing-prototypes
-Wmissing-declarations -Wunused-parameter -Wshadow -Wwrite-strings
-fvisibility=hidden -D_REENTRANT -DCW_API_IMPLEMENTATION
-DCW_UTILSDIR="//sbin" -fomit-frame-pointer -I../libltdl -I../include
-I.. -I../include -I../include -I.. -I../include -g -O2
-fstack-protector -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -MT
callweaver-udpfromto.o -MD -MP -MF .deps/callweaver-udpfromto.Tpo -c -o
callweaver-udpfromto.o `test -f 'udpfromto.c' || echo './'`udpfromto.c
*** Retry without preprocessor compile time optimizations
cc1: warnings being treated as errors
udpfromto.c: In function ‘cw_udpfromto_init’:
udpfromto.c:39: error: unused parameter ‘s’
udpfromto.c: In function ‘cw_recvfromto’:
udpfromto.c:69: error: unused parameter ‘to’
udpfromto.c:70: error: unused parameter ‘tolen’
udpfromto.c: In function ‘cw_sendfromto’:
udpfromto.c:179: error: unused parameter ‘from’
udpfromto.c:180: error: unused parameter ‘fromlen’
make[3]: *** [callweaver-udpfromto.o] Fehler 1

Mike Jagdis schrieb:

Quote:
On Thu, Apr 08, 2010 at 03:06:58PM +0200, Peter P GMX wrote:


Quote:
[...]

I tried to compile CW 1.9.99.20100406 with no success. In jitterbuffer I get
../../include/callweaver/atomic.h:97: error: unused parameter ‘mutex’


I guess it's been a while since I've had anything non-64bit and the
ifdef for x86_64 is broken (possibly I was testing and forgot about it)
so that has been compiling the pthread fallback atomics rather than the
native implementation.

Either grab the latest as of today or insert a CW_UNUSED(mutex) in
atomic.h around line 99 or so - it doesn't need to be exact.
(See the changesets at http://www.callweaver.org/ if you are in
any doubt).

Mike



_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users

_______________________________________________
Callweaver-users mailing list
Callweaver-users@callweaver.org
http://lists.callweaver.org/mailman/listinfo/callweaver-users
Back to top
Display posts from previous:   
Post new topic   Reply to topic    VoIP Mailing List Archives Forum Index -> CallWeaver Users All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group

VoiceMeUp - Corporate & Wholesale VoIP Services